Anonymous
Anonymous asked in Consumer ElectronicsMusic & Music Players · 1 decade ago

iPod Touch and iTunes problems, iTunes freezes up when iPod is connected. Any sudgestions?

Every time i connect my iPod touch to my computer iTunes freezes. I let it sit for an hour and there is still no response. I tried it on my moms computer and iTunes froze up, BUT i saw the sync screen on my iPod Touch, i cancled the sync and iTunes unfroze. Im thinking that maybe iTunes is freezing becuase i have iTunes sync my photos when i hook up my ipod. is there any way to stop synicing without hooking up my iPod.

Is there anything else that may be causing this problem?

And ideas?

I already searched the net, went to various iPod touch sites, apple.com, etc and i am still at a loss.

5 Answers

Relevance
  • 1 decade ago
    Best answer

    Check to make sure you have the latest version of iTunes. Also check the minimum requirements for the iPod. It may not be compatible with your computer. Also make sure your version of Windows is completely updated. You can always visit an Apple Store and talk to one of their Geniuses. They don't call 'em that for nothing!

    If all else fails, just recycle that PC of yours and buy a Mac. That's what they REALLY want you to use with you iPod.

  • Anonymous
    1 decade ago

    is your computer a dell notebook? Ive heard this once before on a dell xps notebook, and it happens to me too on my dell e1705 notebook. Works fine on bro's computer. I bought a widock, it syncs the ipod thru wifi instead of usb, slower transfer, but its my work around since I don't want to shell out for a new computer. Not sure if it will fix the problem as i haven't got the widock in the mail yet. Its made for last gen ipods but those docks are universal. On a side note, my 5.5 gen ipod with video had problems with my notebook. It would sync itself then suddenly eject itself when done. It wouldn't stay in the list of connected devices and I couldn't sync it again manually by clicking "sync" in itunes. My only way to resolve this was by enabling hard disk use, I had to turn it on before it was done syncing, cuz u can only enable it while the the device is present. It worked for keeping it from ejecting itself when 80gig video ipod was done sncing. Sadly, Hard disk use is disabled on the new ipods. I believe the problem we and the other guy with an xps are experiencing is caused by insufficent power provided by the usb slots. I think my laptop is cutting off the power due to an internal power saving scheme, that I am unable to correct. If u dont have a laptop, I recommend making sure its plugged directly into your computer, not a usb port of your connected keyboard. Also try multiple usb ports on your computer, not just one and disconnect all other devices running from usb (i.e.. printers keyboard and mouse (if usb), game controllers. I think the case is insufficent usb power . Reinstalling itunes couldn't hurt your cause.

  • Asif
    Lv 5
    1 decade ago

    Hi,

    There is a setting in the iTunes. There is an option to stop the iPod from syncing everytime you connect. Am not sure on the menu navigation, but you can find iPod Preferences in Settings Menu. There will be a checkbox which says like Sync me everytime i connect the iPod. Just uncheck it, and you will be fine,

    Thanks. Hope i helped :)

  • 1 decade ago

    If you have all your music backed up on your computer, you may want to consider doing a full format of the ipod touch. then update your itunes to the newest version. Also check to see if there is a firmware update for the touch. Once this is all done, you should be all set to sync it up.

    Source(s): iPhone & iPod Accessories: http://www.iPhods.com/
  • What do you think of the answers? You can sign in to give your opinion on the answer.
  • 1 decade ago

    mine does the same thing when i use windows xp, but is fine when i connect it in windows vista..i think its an xp thing....and it really sucks if winxp is all u got..they gotto fix it..hope this helps

Still have questions? Get answers by asking now.