Why does my email display that it is from "Me" or to "Me"and not my address?

This started about two weeks ago. I cannot find the setting to change it

1 Answer

Relevance
  • 7 years ago
    Favourite answer

    You can turn conversations off.

    Go to the Gear icon and select settings.

    Click on "viewing email".

    Uncheck "enable conversations".

    ℬ ℋ

Still have questions? Get answers by asking now.