I just bought an apple MacBook air (since I cannot find Apple MacBook anywhere anymore) my software won't install?

I did the remote disc function and tried to install all of the software from my previous Macintosh computer. 

The software won't open giving me a message 'the classic environment is no longer supported.' The application has a white circle with a line through it sign on it.

What should I do? 

Update:

New 2019 MacBook air space gray latest os

5 Answers

Relevance
  • 3 weeks ago
    Favorite Answer

    The programs you are trying to install ran on an old version of the MacOS. Please note that any 32-bit programs will not run on Catalina, which will only support 64-bit programs. You will have to search to see if there are newer 64-bit versions of those programs in order to run them under Catalina. (I'm avoiding upgrading because most of the games I play—PopCap puzzle games—are 32-bit.)

  • 3 weeks ago

    I've read the question and the other posts. If you backed up your old Mac in Time Machine, you can install, run Parallels and VR macosX Mojave and / or Leopard. The Classic Environment was the support of OS9 Apps on an Intel Mac from years ago. Either OSX Leapord or Snow Leapord were the last OSes to support the Classic Environment. They do run very well as virtual machines. Once you install either of those, you can use the Migration Assistant to put your stuff from Time Machine into the new VM's. And off you go. That would be the easiest work around to run all of your older apps without having to buy replacement software.

    • Bob3 weeks agoReport

      MacOS 10.4.7 (Tiger) was the last OS supporting Classic Environment

  • Dave
    Lv 7
    3 weeks ago

    You need to be way more specific. What version of OSX are you using? What programs are failing to install? We can't read your mind.

  • 3 weeks ago

    What kind of programs are you trying to install? I'm not an expert on Macs, but from what I found, it seems that you're trying to launch really old programs from the 90s or at least ones that were developed for Mac OS 9. Is that right? If so, then those programs will no longer work  modern editions of macOS.

  • What do you think of the answers? You can sign in to give your opinion on the answer.
  • Anonymous
    3 weeks ago

    Presumably the issue is that your software is too old to run on the new OS.  You can try to locate updated versions, or newer software with similar functionality.

    • I would then have to rebuy the software again since the other ones don't work anymore 

Still have questions? Get answers by asking now.