New laptop wont connect to internet?

Just bought a new Lenovo laptop. On starting it up for the first time it asked for my internet password. Which I put in and I kept getting this message "failed to connect to network. Bad password."

So I turned it off, unplugged it. And turned off mu internet (think it's called a router in US but it's called a hub in the UK). Left it 5 minutes.

Restarted hub and waited for it to turn blue. Started up lenovo again and exact same thing. It's the correct password. I've retyped it several times still same thing. Yet this laptop is working off that hub just fine.

How can I fix the problem?


Norman - I just tried it and nothing. Thanks for the suggestion though

8 Answers

  • 2 months ago

    Please check the network cables or LAN cables first.

  • 2 months ago

    Are you sure you're connecting to your wifi, and not your neighbours?

  • Olive
    Lv 7
    2 months ago

    Try this if get Failed To Connect To Network: 1. Press Menu on Homescreen 2. Tap Settings 3. Tap on More 4. Network Settings Reset 5. Tap on Reset Settings 6. Tap on Reset Settings to again Confirm

  • 2 months ago

    You need to use the correct security encryption that your router is set to......

  • What do you think of the answers? You can sign in to give your opinion on the answer.
  • 2 months ago

    RMA this sucker.  Seems to me this supposedly new product was previously set up by someone else who set a password and then returned it.  Or else demand that store make it work properly on pain of rescinding the sale completely

  • 2 months ago

    Some goof, must have changed the password, while it was in the store!

  • David
    Lv 7
    2 months ago

    1)When you are typing the password can you actually see the characters or are they starred out? - if the keyboard is set to another language or caps lock is on then you may inadvertently be entering different characters

    2)log into the router and check the wifi is set to one of these modes:

    802.11a/b/g/n and 802.11ac standards for AC equipped Chromebooks

    Secure networks that use WEP, WPA-PSK, or WPA-Enterprise settings.

    3)If the router settings are correct, As mentioned in your other post contact Lenovo or the shop for a swapout in case it is faulty

  • ?
    Lv 5
    2 months ago

    Tried pressing the association button on top of the router? Mine's a BT Hub and it says "Wireless WPS" on it. My latest laptop connected without the need for the password.

Still have questions? Get answers by asking now.