GPU ports no working - Monitor No signal?

I have tried both HTMI and DVI ports on my GPU and they will not let my monitor display work. They always worked in the past just recently my computer stopped working. If I plug my monitor DVI or HDMI to my Motherboard the screen will show. It's only when I use my GPU that it won't.

What can or should I do? Thanks 

5 Answers

Relevance
  • 2 months ago

    Reboot your computer, using your onboard graphics, and enter your system BIOS ... sorry, but as you make no mention of your motherboard I can't say which key you need to press, but this is LIKELY displayed when the image appears onscreen.

    Look for display options and make sure that you have discrete video/graphics selected.

    Save your new BIOS information and reboot your computer.  Plug the video cable into one of your video card's ports and see if it is now working.

  • keerok
    Lv 7
    2 months ago

    You did what you can and it's pretty obvious. Time to replace the GPU already.

  • 2 months ago

    Do you have any idea why DP may not provide any signal? ... After deleting NVIDIA drivers etc. to no avail I tried simply unplugging my monitor's ... My DVI was fine but the display port and HDMI were not responding at all.

  • David
    Lv 7
    2 months ago

    If the power cables are connected and it still doesn't work, it has died.

  • What do you think of the answers? You can sign in to give your opinion on the answer.
  • 2 months ago

    Should make sure when you have the GPU connected with the necessary cables from the Power Supply attached.

    Attachment image
Still have questions? Get answers by asking now.